Author Topic: HM01 13-Apr-2018 and DIGTRX Issue  (Read 186 times)

K5KNT

  • Full Member
  • ***
  • Posts: 109
    • View Profile
HM01 13-Apr-2018 and DIGTRX Issue
« on: April 13, 2018, 2256 UTC »
13-Apr-2018 2155UTC 10715 kHz KiwiSDR, Kansas, USA

DIGTRX crashed twice at the beginning but then ran smoothly until my browser froze at approx 2210UTC. I happened to open the program folder while it was decoding and noticed that it was overwriting the currently saved decoded file even if it was a different file name. This included both .txt and .f1x files. I finally started dragging the file to my desktop to save them. I only managed to save six.

Has anyone had this situation? Any known fix? In the setup > Options, the "overwrite repeated Rx file" is unchecked.


Thanks,

K5KNT

K5KNT
Grand Forks, ND, USA

MDK2

  • DX Legend
  • ******
  • Posts: 2295
    • View Profile
    • My radio reception videos
Re: HM01 13-Apr-2018 and DIGTRX Issue
« Reply #1 on: April 14, 2018, 0318 UTC »
I've never had that problem. And I DO have that checkbox checked. To the best of my recollection, that's its default and is something I never changed. Maybe it's happening because you have it unchecked?

What I would do is check that box again, then tune in for a full hour broadcast and keep an eye on the autosave folder to see if that happens. Move any existing files out first, but let it do it's thing. It should decode all six files that are sent, then repeatedly overwrite each one as it decodes a repeat. HM01 sends each file 12 times in an hour (six in one half, six in the second), but at the end of that hour you should be left with just the six files that were transmitted.

Good luck!
Denver, CO.
Grundig Satellit 750, Tecsun PL-600, SDRPlay RSP2 Pro.
W6LVP active loop and two homebrewed mag loops (10' and 15' circumference).
eQSL's appreciated, wickerjennie (at) gmail

K5KNT

  • Full Member
  • ***
  • Posts: 109
    • View Profile
Re: HM01 13-Apr-2018 and DIGTRX Issue
« Reply #2 on: April 14, 2018, 0823 UTC »
OK, now I feel stupid. I was watching the main DIGTRX folder and didn't even see the autosave folder until now. My files are there. Can we compare settings? I also have "Rx ON while decode" and "Accept bad blocks!" also checked in Options. I have also checked "Overwrite repeated Rx file" since you have it checked and I see I now have multiple files in that autosave folder.

Edit to add: Now I just need to figure out why there is no audio in my OBS recording. I was going to get the voice numbers from that.

Thanks.

K5KNT
K5KNT
Grand Forks, ND, USA

MDK2

  • DX Legend
  • ******
  • Posts: 2295
    • View Profile
    • My radio reception videos
Re: HM01 13-Apr-2018 and DIGTRX Issue
« Reply #3 on: April 14, 2018, 1246 UTC »
Yes, I have those checked off too. Anyway, glad to see that your autosave is doing what it should. That's the important folder because that's where it stores the good decodes. You probably noticed the "corrupt" folders. Those files are no good, obviously.

I don't use OBS, but I imagine it's similar to the program I use, Bandicam. Check the recording settings. There's probably something in there for sound card settings. Are you using a virtual audio cable program? If not, you can install one and it makes it easy to manage the sound card settings.
Denver, CO.
Grundig Satellit 750, Tecsun PL-600, SDRPlay RSP2 Pro.
W6LVP active loop and two homebrewed mag loops (10' and 15' circumference).
eQSL's appreciated, wickerjennie (at) gmail

K5KNT

  • Full Member
  • ***
  • Posts: 109
    • View Profile
Re: HM01 13-Apr-2018 and DIGTRX Issue
« Reply #4 on: April 14, 2018, 1407 UTC »
Thanks. I am using a virtual audio cable program. I discovered that I had the wrong input selected on OBS for the desktop audio.  HM01 was just starting and I hurried to get things up and running. I didn't notice that there was no audio on OBS.  I tested it using a broadcast station and found that the input setting was the problem. Hopefully, everything should be good to go now.

How often do you empty the autosave and "corrupt" folders?
K5KNT
Grand Forks, ND, USA

MDK2

  • DX Legend
  • ******
  • Posts: 2295
    • View Profile
    • My radio reception videos
Re: HM01 13-Apr-2018 and DIGTRX Issue
« Reply #5 on: April 14, 2018, 1446 UTC »
I haven't emptied them, I don't think. I like having the originals and at about 1 kB each, they don't take up much space. It's up to you what to do with them.
Denver, CO.
Grundig Satellit 750, Tecsun PL-600, SDRPlay RSP2 Pro.
W6LVP active loop and two homebrewed mag loops (10' and 15' circumference).
eQSL's appreciated, wickerjennie (at) gmail

Ary-B

  • Sr. Member
  • ****
  • Posts: 319
    • View Profile
    • Numbers & Oddities
Re: HM01 13-Apr-2018 and DIGTRX Issue
« Reply #6 on: April 18, 2018, 1649 UTC »
DIGTRX crashes all the time. It did that on my old Vista, on Win7 32bit, Win764bit and Win8.1. No idea what causes it. It sometimes runs for 20 mins or so but most of the time it crashes within 5 mins. I tried to run it as Admin but that didn't help.

Ary