We seek to understand and document all radio transmissions, legal and otherwise, as part of the radio listening hobby. We do not encourage any radio operations contrary to regulations. Always consult with the appropriate authorities if you have questions concerning what is permissable in your locale.

Author Topic: kiwi software glitches or just problems at KFS?  (Read 210 times)

Offline Teotwaki

  • DXing Phenomena
  • *******
  • Posts: 2817
  • California
    • View Profile
    • My adventures are at Sun To The North
kiwi software glitches or just problems at KFS?
« on: May 04, 2022, 1537 UTC »
I've already sent an email to the KFS folks but no response.

On my iPhone and on my laptop's Chrome & Firefox browsers I've been seeing the same issue: After going to the main quad kiwi page at
http://kiwisdr1.kfsdr.org:81/

I have experienced the following:

selecting any of the four kiwis brings up a page that has a blank frequency box and even though I type in a frequency and hit return nothing happens on Chrome and on IOS it reloads to display the "Play" arrow icon in the middle of the screen. The screen also does not populate my ID in the name/callsign box as it used to.

The problem seems to come and go. I noticed that it seemed to have started after their domain was remapped but maybe it is due to a recent software release. The ham radio page at http://websdr1.kfsdr.com:8901/ seems to function normally for me.

I don't want to send more emails to the KFS crew unless I can provide something useful so I thought I'd see if this is only something I have experienced or if it is more widespread.

Thanks!


Jim
Jim
NRD-525, Elecraft KX3 and Elecraft PX3 Spectrum Display
76' end fed long wire & 66' off-center fed dipole for 10/20/40 meters
Orange County, SoCal, The better half

Offline Charlie_Dont_Surf

  • Full Member
  • ***
  • Posts: 228
  • Charlie's Point, California
    • View Profile
Re: kiwi software glitches or just problems at KFS?
« Reply #1 on: May 04, 2022, 1723 UTC »
After going to the main quad kiwi page at
http://kiwisdr1.kfsdr.org:81/

selecting any of the four kiwis brings up a page that has a blank frequency box and even though I type in a frequency and hit return nothing happens on Chrome and on IOS it reloads to display the "Play" arrow icon in the middle of the screen.


I can confirm this happening to me on Firefox for Windows 99.0.1, Windows 10.

I noticed this morning that if I closed that browser tab and open it again a few minutes later (I went to get a coffee), it opened with 10 MHz WWV in use (as usual) and that may have been because someone in Switzerland had swooped in and grabbed the RX0 position. I don't know if that Swiss user had to do some extra gymnastics to get it to go to 10 MHz or not.

I don't use KFS that often (because it is quite popular) but by chance I used it last night (the first time in probably at least a month) and I noticed something similar. (I accessed the Omni from a saved bookmark, not from the "top level" menu you posted) and the first thing that I noticed is that the frequency input was not responding to changes. I ended up going somewhere else.

I have noticed similar weird behavior on certain Kiwis lately. (E.g., not responding to frequency changes.) It's random and not 100% repeatable. I have not made notes about which ones and when.

I don't STRETCH the truth.

"Every minute I spend in this room, my signal gets weaker.
Every minute Charlie squats in the bush, his signal gets stronger."

Offline Teotwaki

  • DXing Phenomena
  • *******
  • Posts: 2817
  • California
    • View Profile
    • My adventures are at Sun To The North
Re: kiwi software glitches or just problems at KFS?
« Reply #2 on: May 04, 2022, 2026 UTC »

I can confirm this happening to me on Firefox for Windows 99.0.1, Windows 10.

I noticed this morning that if I closed that browser tab and open it again a few minutes later (I went to get a coffee), it opened with 10 MHz WWV in use (as usual) and that may have been because someone in Switzerland had swooped in and grabbed the RX0 position. I don't know if that Swiss user had to do some extra gymnastics to get it to go to 10 MHz or not.

I don't use KFS that often (because it is quite popular) but by chance I used it last night (the first time in probably at least a month) and I noticed something similar. (I accessed the Omni from a saved bookmark, not from the "top level" menu you posted) and the first thing that I noticed is that the frequency input was not responding to changes. I ended up going somewhere else.

I have noticed similar weird behavior on certain Kiwis lately. (E.g., not responding to frequency changes.) It's random and not 100% repeatable. I have not made notes about which ones and when.

Thanks! Your comments might support that there is a small s/w issue with a recent kiwi release. Maybe I'll contact whoever releases the s/w and see what they think.

Jim
Jim
NRD-525, Elecraft KX3 and Elecraft PX3 Spectrum Display
76' end fed long wire & 66' off-center fed dipole for 10/20/40 meters
Orange County, SoCal, The better half

Offline Charlie_Dont_Surf

  • Full Member
  • ***
  • Posts: 228
  • Charlie's Point, California
    • View Profile
Re: kiwi software glitches or just problems at KFS?
« Reply #3 on: May 04, 2022, 2129 UTC »
Thanks! Your comments might support that there is a small s/w issue with a recent kiwi release.

Yeah, maybe it is the software. It might be platform-specific or it might not. I don't know. The first thing I would do is have the KFS people reboot their computer(s).  :)
I don't STRETCH the truth.

"Every minute I spend in this room, my signal gets weaker.
Every minute Charlie squats in the bush, his signal gets stronger."

Offline Teotwaki

  • DXing Phenomena
  • *******
  • Posts: 2817
  • California
    • View Profile
    • My adventures are at Sun To The North
Jim
NRD-525, Elecraft KX3 and Elecraft PX3 Spectrum Display
76' end fed long wire & 66' off-center fed dipole for 10/20/40 meters
Orange County, SoCal, The better half

Offline Teotwaki

  • DXing Phenomena
  • *******
  • Posts: 2817
  • California
    • View Profile
    • My adventures are at Sun To The North
Re: kiwi software glitches or just problems at KFS?
« Reply #5 on: May 05, 2022, 1526 UTC »
I posted the issue to the kiwi sdr forum

https://forum.kiwisdr.com/index.php?p=/discussion/2605/possible-bug-with-public-facing-gui#latest

Comment from that kiwi forum

Comments
jksjks
May 4
Wow, there's something really strange about all 4 of those Kiwis. They're all running v1.509 which is a little old but should be okay. If you look at the javascript console (from the browser) on page load it thinks the variable "cfg.passbands" doesn't exist. That comes from the saved configuration file. Yet if you type "cfg.passbands" into the javascript console input field it appears just fine.

So I don't get it. One of them has been up 10 days, but another less than 24 hours. Maybe they should try updating to the latest software version and see what happens. You'll note there is no waterfall either because of this problem (because the javascript aborts before the page can completely load).
Jim
NRD-525, Elecraft KX3 and Elecraft PX3 Spectrum Display
76' end fed long wire & 66' off-center fed dipole for 10/20/40 meters
Orange County, SoCal, The better half

Offline Teotwaki

  • DXing Phenomena
  • *******
  • Posts: 2817
  • California
    • View Profile
    • My adventures are at Sun To The North
Re: kiwi software glitches or just problems at KFS?
« Reply #6 on: May 09, 2022, 0415 UTC »
Someone from KFS is attempting to fix the issues but it's not fast or easy
Jim
NRD-525, Elecraft KX3 and Elecraft PX3 Spectrum Display
76' end fed long wire & 66' off-center fed dipole for 10/20/40 meters
Orange County, SoCal, The better half

Offline Teotwaki

  • DXing Phenomena
  • *******
  • Posts: 2817
  • California
    • View Profile
    • My adventures are at Sun To The North
Re: kiwi software glitches or just problems at KFS?
« Reply #7 on: May 15, 2022, 1754 UTC »
It appears that the issues at KFS have been resolved. All of the KFS kiwis are now on the latest software revision. One interesting item in the discussion was:

" The KFS site is connected to the Internet by a microwave link which is heavily used by WebSDR listeners as well as by one of the wsprdaeon.org backup servers. I am working both the reduce the network impact of the WD server and to increase the subscription bandwidth of the link."
Jim
NRD-525, Elecraft KX3 and Elecraft PX3 Spectrum Display
76' end fed long wire & 66' off-center fed dipole for 10/20/40 meters
Orange County, SoCal, The better half